You dont have javascript enabled! Please download Google Chrome!

Error: GDK_BACKEND does not match available displays 해결


글붕어 - 2018-06-30 - 0 개의 댓글

Error: GDK_BACKEND does not match available displays


X11 포워딩으로 어플리케이션을 GUI 형식으로 실행할 수 있습니다. 그러나 아래와 같이 X11 어플리케이션 실행에 실패하는 경우가 있습니다.

 

[user@centos ~]$ firefox
Error: GDK_BACKEND does not match available displays

이 문제는 xauth와 관련이 있습니다. xauth는 쿠키 기반의 X Windows Authorization을 위해 사용되며 .Xauthority 파일에 접근할 수 있도록 하는 어플리케이션입니다. xauth 패키지가 설치되지 않는다면 위와 같은 에러가 발생할 수 있습니다.

 

해결 방법


아래 명령어로 xauth 패키지를 설치하면 해결할 수 있습니다.

# yum install xorg-x11-xauth
또는
# yum install xauth

 

 

이 글에 대해 어떻게 생각하시나요?
유용한 포스트였나요? 여러분의 의견을 하단의 Vote와 댓글로 남겨주세요 🙂
유용합니다!
아쉽습니다.

관련 포스트

댓글 달기

이메일은 공개되지 않습니다.

error: 경고: 콘텐츠가 보호되고 있습니다. 복사 및 무단 사용을 금지합니다.